Noise or volume issues with the receiver of the P30 Pro/Mate 30 Pro/Mate 30 RS/P40 series
Applicable products:
zoom in pic
Noise or volume issues with the receiver of the P30 Pro/Mate 30 Pro/Mate 30 RS/P40 series

Problem:

When making a call or listening to a voice message using the P30 Pro, Mate 30 Pro, Mate 30 RS, or P40 series, the sound is intermittent or weak, or other noise is audible from the receiver.

Cause:

The possible causes are as follows:

  • The P30 Pro/Mate 30 Pro/Mate 30 RS/P40 series feature acoustic display technology to deliver high-quality sound and a wider area of sound compared to traditional screens. The recommended position to place your ear would be about 2 cm (about 0.8 in.) from the top edge of your phone. The volume may be weaker if the phone is in a different position to the recommended position. If you move your phone during a call or voice chat, you may encounter a change in volume or other noise being audible.
  • The P40 series phones incorporate an intelligent volume adjustment function so that the volume of your calls will be lowered in a quiet environment to protect your call privacy.
  • The sound quality of your phone may be affected if the screen is covered by a third-party screen protector that has not been tested by Huawei.
  • If your phone is covered by a flip cover that is closed during calls, the in-call audio has to pass through an extra medium in the form of a leather case. In this case, it will impair the call quality.
  • Earrings may make a noise if they touch the screen.
  • Poor signal or network quality will impair the call or online chat sound quality.

Solution:

  • Slightly move your phone upwards when using the receiver, and make sure your ear is about 2 cm (about 0.8 in.) from the top edge of your phone. (Your phone will display tips for the recommended position to place your ear within 2 weeks after your phone is initially activated.)

  • Update your P40 series phone to EMUI 10.1.122 or later. During a call, increase the call volume to the maximum. If you still feel that the sound is weak, keep pressing the Volume up button to disable the intelligent volume adjustment function, and you will be able to further increase the call volume.
  • Remove any third-party protective film, or replace it with a Huawei protective film.
  • Open the flip cover when making a call or voice chat and make sure your ear is close to the phone screen.
  • Avoid touching the screen with your earrings.
  • Move to a location with good signal reception and network quality.

If the issue persists, back up your data and take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance.

More:

My phone's speaker has no sound, weak sound, or disruptive noise

Helpful or not?
Thanks for your feedback.