Slow startup on my HUAWEI computer
Slow startup on my HUAWEI computer |
Problem
The computer takes a long time to load and start up.
Cause
- Too many programs or services are automatically running at startup, which slows down startup performance.
- Junk files, when not deleted in a timely manner, clog up the system and eat up valuable disk space.
- There are bad sectors on a hard drive.
- There is a conflict with third-party software.
- System patches or drivers are not properly updated.
- Too many partitions have been created on a hard drive.
- Others, such as connection of an external connecting device.
Solution
- Optimize startup programs and services.
- Huawei PC Manager provides a one-click optimization function for auto-startup item management and performance improvement.
To access this feature, open Huawei PC Manager, and go to Optimization > Full scan > OPTIMIZE.
- Enable clean startup following the steps as stated in Perform a clean boot in Windows.
- Huawei PC Manager provides a one-click optimization function for auto-startup item management and performance improvement.
- Defrag your hard drives and clean up junk files from the system drive.
- Go to Windows (C:) > Users > Your Windows username and back up your personal files. Access This PC, right-click on the drive that you want to defrag, and select Properties. Go to the Tools tab and click Optimize.
- After you selected Optimize, defragging will be performed.
(1) Defragmenting is not recommended for solid state drives (SSDs). SSDs organize or write data differently from hard drives, and the data on an SSD is not fragmented. Defragging SSDs not only uses up write cycles, but also shortens their lifespan and reduces reliability.
(2) If the Optimize button is grayed out and unavailable, it indicates that the selected drive does not support defragmentation.
- Clean up your system drive following the steps carefully to free up drive C space, until the drive has 15 to 20 GB of available space.
Deleted files from drive C cannot be recovered. Make sure to back up important data in drive C to a non-system drive (such as drives D and E) or an external storage device.
- Scan and repair drives.
- Access This PC. Right-click on the drive (for example, C:/D:) that you want to repair and select Properties
- Select the Tools tab and click Check.
- Click Scan Drive.
- The computer runs a disk check (for C:, D:, E:, and F:, etc.) at every startup. Too many disk partitions increase scanning time and slow down startup performance. Generally, it is advised to keep no more than four partitions. If you do need more partitions, back up your data on non-system drives (drives other than C:) and allocate more disk space to drive C following the steps as stated in Merging the C drive with other drives.
- Uninstall third-party antivirus programs and unwanted software.
Multiple types of antivirus programs on your computer can cause system crash or performance slowdown, since such programs are often mutually interfering and require high-level system permissions. It is advised to retain only the pre-installed Windows Defender Antivirus and uninstall other antivirus programs:
- Use the keyboard shortcut Win+R to access the Run command. Enter "appwiz.cpl" and then click OK.
- In the displayed Programs and Features window, right-click on the unwanted antivirus software and select Uninstall/Change.
- It is recommended that you also uninstall any unused software, junk apps that you have not installed, or non-official programs from the Programs and Features list.
- Back up important data and update the operating system to the latest version by following the steps as stated in Updating to a higher version of Windows. Open Huawei PC Manager, go to Optimization > Drivers, click CHECK or UPDATE in the upper right corner, and follow the onscreen instructions to update all drivers to the latest version.
- For optimal startup experience, it is recommended that external devices such as monitors, projectors, and external hard drives be disconnected from the computer during startup.
If the issue persists
Back up your data, record your Office account, and follow the instructions in Use F10 to restore factory settings on a HUAWEI Windows computer. If none of the above solved the problem, take your device and proof of purchase to an authorized Huawei Customer Service Center for further assistance. We will do our best to address your needs.