Unable to switch from Wi-Fi to mobile data on a HUAWEI phone/tablet
| Unable to switch from Wi-Fi to mobile data on a HUAWEI phone/tablet |
Problem:
When Wi-Fi is disabled, the phone/tablet cannot switch to mobile data automatically.
Cause:
- This feature may not be enabled on your device.
Solution:
- Open Settings, search for and tap Wi-Fi/Mobile data switch, and select . Your device should then automatically switch to mobile data after Wi-Fi is disabled.
Problem 2:
When Wi-Fi+ is enabled on the phone and the Wi-Fi signal quality is poor, the phone doesn't switch to mobile data.
Cause:
- If the signal quality of the current Wi-Fi network is poor, your phone/tablet will automatically switch to another available Wi-Fi network that it detects.
- If the mobile data signal is poor, the mobile data service is unavailable, or the data service is roaming outside China, your device will not switch to mobile data.
Solution:
- Make sure your mobile data service is not in an international roaming state.
- Swipe down from the status bar on your phone/tablet to open the shortcut menu, turn on the Mobile data switch, and then access the Internet in a place with good mobile data quality.

If the issue remains unresolved, contact the Huawei customer service hotline, or back up your data and take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance.