Unable to receive message notifications from my watch unless I open the HUAWEI FamCare app on my third-party Android phone/HUAWEI phone
Applicable products:
Unable to receive message notifications from my watch unless I open the HUAWEI FamCare app on my third-party Android phone/HUAWEI phone |
Problem
The user can't receive notifications on their watch, such as chat messages and notifications for entering/exiting safe zones, video calls, scheduled shutdown, and rewards, unless they open the HUAWEI FamCare app.
Cause
- Message notification permissions have not been enabled for the HUAWEI FamCare app.
- Background protection has not been properly set for the HUAWEI FamCare app or HMS Core, causing it to be cleared from the phone's background.
Solution
- Enable message notification permissions for the HUAWEI FamCare app. Using a HUAWEI phone as an example: On your phone, go to Settings, search for and access Apps, go to HUAWEI FamCare > Notifications management, and enable Messages. (The exact steps will vary depending on the phone model that you are using.)
- Ensure that you have correctly set background protection for the HUAWEI FamCare app and HMS Core.
If the issue persists, it may be because the HUAWEI FamCare app or HMS Core is cleared from the background when your phone's internal storage is low. Other causes include restarting your phone or updating your phone or app. To troubleshoot, manually restart the HUAWEI FamCare app and try again.
Thanks for your feedback.