Unable to receive message notifications from my watch unless I open the HUAWEI FamCare app on my phone

Applicable products:
  • 请选择

zoom in pic
Unable to receive message notifications from my watch unless I open the HUAWEI FamCare app on my phone

Problem

The user can't receive notifications from their watch, such as chat message notifications, notifications for entering/exiting safe zones, video call notifications, scheduled shutdown notifications, and SOS notifications sent by the watch, unless they open the HUAWEI FamCare app on their phone.

Cause

  1. The message notification permission has not been enabled for the HUAWEI FamCare app.
  2. The HUAWEI FamCare app is cleared from the background.

Solution

  1. Enable the message notification permission for the HUAWEI FamCare app.
    • HUAWEI phones: Open Settings, search for and access Apps, go to HUAWEI FamCare > Notifications management, and enable Allow notifications.

    • iPhones: Go to Settings > Notifications > HUAWEI FamCare, toggle on the Allow Notifications switch, and select Notification Center. Select Always for Show Previews.

      If your iPhone runs iOS 15 or later, go to Settings > Focus. If Focus is enabled, disable it and try again.

    • Third-party Android phones (for example, Xiaomi): Go to Settings > Notifications & status bar > Notification management > HUAWEI FamCare, toggle on the Allow Notifications switch, and enable Floating notifications and Lock screen notifications. (The actual steps may vary depending on the phone model.)
  2. Set background protection for the HUAWEI FamCare app.
    • HUAWEI/Third-party Android phone: Make sure that you have set background protection for the HUAWEI FamCare app and HMS Core. For details, see here.

      If the issue persists, it may be because the HUAWEI FamCare app or HMS Core is cleared from the background when your phone's internal storage is low. Other causes include restarting your phone or updating your phone or app. To troubleshoot, restart the HUAWEI FamCare app and try again.

    • iPhones: Go to Settings > HUAWEI FamCare and turn on Background App Refresh. In addition, keep HUAWEI FamCare running in the background, and do not swipe up on its preview to close the app.

      iPhones: iOS has a memory management mechanism which clears apps that have been running in the background for long periods of time, so as to ensure smooth system running and power efficiency. It's recommended that you open the HUAWEI FamCare app regularly to prevent it from being cleared.

    If the issue remains unresolved or you encounter any difficulties, please call the Huawei customer service hotline for further assistance.

Helpful or not?
Thanks for your feedback.