My HUAWEI computer cannot find a Wi-Fi network or frequently disconnects from the Internet after connecting to a Wi-Fi network

Applicable products: PC,Desktop
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My HUAWEI computer cannot find a Wi-Fi network or frequently disconnects from the Internet after connecting to a Wi-Fi network

Problem

  • The computer cannot find a network.
  • The computer frequently disconnects from the Internet after connecting to a Wi-Fi network.

Cause

  • The computer is far away from the router, so it cannot receive Wi-Fi signals.
  • The router or network environment is abnormal.
  • The refresh intervals of the operating system, underlying driver, and wireless hotspot are not synchronized.
  • The network configuration of the computer is abnormal.
  • The network adapter driver is not up to date or the driver status is unstable.

Solution

  1. Move the computer close to the router, set MIMO Power Save Mode to No SMPS (if an Intel network adapter driver is used), and set Power mode to Best performance to enhance the computer's capability of receiving Wi-Fi signals. To do so, perform the following:
    1. Press Win+X, select Device Manager, and double-click Network adapters.

    2. Right-click Intel(R) Wireless-AC 9560 or Intel(R) Wi-Fi 6 AX20* and go to Properties > Advanced. Click MIMO Power Save Mode, select No SMPS from the Value list on the right, and click OK.

      Performing this step will disconnect the network. After the network is disconnected, reconnect to the network.

    3. Set Power mode to the high performance mode.
      • For Windows 10, set the power plan to Maximum Performance.
        1. Enter Control Panel in the search box at the bottom of the computer, open it, and go to Hardware and Sound > Power Options.

        2. Click Change plan settings.

        3. Click Change advanced power settings.

        4. Click Wireless Adapter Settings, select Power Saving Mode, and set On battery and Plugged in to Maximum Performance. (Skip this step if this screen is not displayed.)
      • For Windows 11, go to Settings > System > Power & battery, and set Power mode to Best performance.

  2. Press Win+X, go to Settings > Network & internet > Wi-Fi, and disable Random hardware addresses.

  3. Change the DNS server address: Set the Preferred DNS server address and the Alternate DNS server address to 114.114.114.114 and 8.8.8.8 respectively. For details, see Setting the DNS server addresses.
  4. Connect your computer to another network or mobile data hotspot (try multiple networks if necessary). If your computer can find and connect to other networks and access the Internet, the computer is normal and the issue may be caused by router network restrictions. In this case, power off the router and optical modem, and wait for 5 to 10 minutes before powering on and restarting them again. If the issue persists, it is recommended that you restore the router to its factory settings and reconfigure it.

    The configuration method varies depending on the router vendor. If you have any question when configuring your router, contact the router vendor for assistance.

  5. Back up important data and update the Windows system to the latest version.
  6. Remember the network password and reset the network settings of the computer.
  7. Disable and then restart the network adapter driver. If the issue remains, try uninstalling and reinstalling the latest network adapter driver. To do so, perform the following:
    1. Disable and then restart the network adapter driver: Press Win+X to open Device Manager. Click Network adapters, right-click Intel(R) Wireless AC 9560, and select Disable device. After the network adapter driver is disabled, restart the computer. Then, right-click the network adapter driver again and select Enable device. (Intel(R) Wireless AC 9560 is used as an example.)

      Intel network adapter driver: Intel(R) Wireless-AC 9560 or Intel(R) Wi-Fi 6 AX20*.

      AMD network adapter driver: Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC or Intel(R) Wi-Fi 6 AX201.

      HUAWEI MateBook E Go network adapter driver: Qualcomm QCA639x Wi-Fi 6 Dual Band Simultaneous (DBS) Network Adapter or Qualcomm WCN685x Wi-Fi 6E Dual Band Simultaneous (DBS) WLANCx Network Adapter.

    2. If the issue persists, uninstall and reinstall the Wi-Fi driver. To do so, perform the following:

      [Prerequisite] Ensure that the computer can access the Internet through a wired network or use USB tethering with an Android phone.

      Use USB tethering: Connect an Android phone to the computer using a USB cable, go to the phone's Settings > Mobile network > Personal hotspot > More, enable USB tethering, and wait until the network icon in the lower right corner of the computer changes to the computer icon. Open any website and check that you can access the Internet. Then uninstall and reinstall the network adapter driver.

      If your computer is a HUAWEI MateBook E Go, skip this step.

      1. Uninstall the Wi-Fi driver: Right-click , select Device Manager, and find Network adapters. Right-click Inter(R) Wireless-AC 9560 160MHz, click Uninstall Device, select Attempt to remove the driver for this device, and click Uninstall.

      2. Install the Wi-Fi driver: Restart the computer and connect it to a network via USB tethering. Open Huawei PC Manager, go to Optimization > Drivers, select the wireless network adapter as needed, and click UPDATE.

      3. After the Wi-Fi driver is updated, restart the computer.

If the issue persists

If the issue persists, back up your data, activate your Office account, and use F10 to restore your device to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.

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