My computer lags or artifacts are displayed on the screen when I project it to another device using Miracast
Applicable products: PC,Desktop
Applicable products:
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My computer lags or artifacts are displayed on the screen when I project it to another device using Miracast

Problem

When the computer is connected to the Wi-Fi, the user projects the computer's screen to another device via Miracast, then play videos, music, or view images on the other device and find that the virtual computer's system lags or artifacts are sometimes displayed on the screen.

Cause

The following reasons can cause these issues: multiple devices are currently connected to the router, poor Wi-Fi signal, incompatible video resolution, and low network bandwidth.

Solution

  1. If you have a 5G Wi-Fi hotspot, connect your computer to this hotspot.
  2. Do not move too far away from the other device when projecting the computer's screen, and perform the projection when the Wi-Fi connection is stable.
  3. Restart the computer and the other device, disable Wi-Fi, project the computer's screen to the other device, then enable Wi-Fi again.

Perform the following steps:

  1. Click the Wi-Fi icon to display the Wi-Fi list. Click the Wi-Fi network you are connected to, then click Disconnect.

  2. Click the Action Center icon in the bottom-right corner on the taskbar and go to Project > PC screen only.

  3. Select the other device you want to project your computer's screen to.

  4. After the computer's screen is projected to the other device, enable Wi-Fi again.
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