The system lags or artifacts are displayed during screen casting on my HUAWEI computer

Applicable products: PC,Desktop
Applicable products:
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The system lags or artifacts are displayed during screen casting on my HUAWEI computer

Problem

When the computer is connected to the Wi-Fi, the user casts the computer's screen to another device via Miracast, then play videos, music, or view images on the other device and find that the virtual computer's system lags or artifacts are sometimes displayed on the screen.

Cause

  • This issue is related to the network bandwidth, the number of devices connected to the router, WLAN signal quality, and video resolution. If the network bandwidth is low, the WLAN signal quality is poor, or the video is a high-definition video, the screen may lag or artifacts may be displayed during screen casting.
  • The Microsoft Windows system is incompatible with the screen casting device.

Solution

  1. If the router and the screen casting device are not separated by a wall, connect your computer to the 5 GHz Wi-Fi network first, and then perform screen casting.
  2. For wireless screen casting, please stay close to the TV or target display (within 1-3 meters).
  3. Restart your computer and the target display, and perform the following steps:
    1. Click the Wi-Fi icon to display the Wi-Fi list. Click the Wi-Fi network you are connected to, then click Disconnect.

    2. Press Win+K, select the target display, wait for a while, and check the screen casting effect.

    3. After the screen casting is successful, connect to the Wi-Fi network again.
  4. After uninstalling the Wi-Fi driver, restart the computer and connect to the network. (Connect the computer to the Android phone using a USB cable, go to Settings > Mobile network > Personal hotspot > More sharing settings, enable USB tethering, wait until the network icon in the lower right corner of the computer changes to a small computer icon, open any website, and check whether the Internet can be accessed.) In Huawei PC Manager, reinstall the Wi-Fi driver and restart the computer.

    If you are using a device with an ARM chip architecture processor, such as MateBook E 2019 and MateBook E Go, skip this step.

    1. Uninstall the Wi-Fi driver: Right-click , select Device Manager, and find Network adapters. Right-click Inter(R) Wireless-AC 9560 160MHz, click Uninstall Device, select Attempt to remove the driver for this device, and click Uninstall.

      Intel network adapter driver: Intel(R) Wireless-AC 9560 or Intel(R) Wi-Fi 6 AX2**.

      AMD network adapter driver: Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC or Intel(R) Wi-Fi 6 AX201.

    2. Install the Wi-Fi driver: Restart the computer and connect it to a wired network. Open Huawei PC Manager, go to Optimization > Drivers, select the wireless network adapter as needed, and click UPDATE.

    3. After the Wi-Fi driver is updated, restart the computer.
  5. Uninstall the graphics card driver and then install the latest integrated graphics card driver. This can be done as follows:

    If you are using a device with an ARM chip architecture processor, such as MateBook E 2019 and MateBook E Go, skip this step.

    1. Press and hold Win+X, and go to Device Manager > Display adapters. Right-click Intel (R) *** or AMD ***, and choose Uninstall device from the shortcut menu. In the displayed dialog box, select Delete the driver software for this device, and click Uninstall.
    2. Restart the computer.
    3. Enter the system again, double-click Huawei PC Manager to open it. Go to Optimization > Drivers > CHECK to install the graphics card driver. After the driver is installed, restart the computer and try connecting it to the monitor.
  6. Back up important data and update the system version of your computer to the latest version. For details, see Updating my HUAWEI computer's Windows system to the latest version.
  7. It is recommended that you update the system of the screen casting device to the latest version. For details, see the device user guide or contact the device vendor.

If the issue persists

If the issue persists, back up your data, record your Office account that has been activated, and use F10 to restore your device to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.

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