HUAWEI band/watch displays a charging error message while being charged using a magnetic charging cable
| HUAWEI band/watch displays a charging error message while being charged using a magnetic charging cable |
Problem
When using a magnetic charging cable shown in the following figure to charge a HUAWEI kids watch, the screen displays an error message about abnormal charging.
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Charging Error Message on the Watch/Band |
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Cause
This issue happens when a non-standard charger or cable is used to charge your band/watch, or the cable isn't properly connected.
Solution
Perform the following to troubleshoot:
- Ensure you're using a standard 5 V/1 A charger recommended by Huawei or one with a higher current. Verify the charger is functioning properly by testing it on another device like a phone or charging case.
- If the charger is working properly, check if you're using a non-standard USB cable between the charger and your band/watch. If so, try switching to a different cable and see if the issue is resolved.
- Disconnect your band/watch from the magnetic charging cable, and inspect both the charging contact points and the device's charging area for dirt or debris. If you find any, use a dry soft cloth to wipe them clean. Reconnect your band/watch to the charging cable, ensuring it makes full contact. If the error message disappears and the charging icon displays properly, the issue has been resolved.

If the issue persists
If the issue persists or you encounter other problems, back up your data and take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. We will do our best to address your needs.
