Unable to write on my tablet with a HUAWEI M-Pencil Series stylus
Unable to write on my tablet with a HUAWEI M-Pencil Series stylus |
The following applies only to HUAWEI tablets. If you are using a 2-in-1 laptop, refer to Unable to use the stylus connected to MateBook E Go.
Problem
The user connects an M-Pencil Series stylus to their tablet, but cannot use it to write or perform operations on the screen.
Cause
- Non-HUAWEI magnetic case or protective film may interfere with the stylus.
- Another Bluetooth device has been connected. For example, when the tablet is connected to a Bluetooth keyboard, some functions of the stylus may become unavailable (for example, FreeScript won't provide the toolbar).
Solution
- Check whether the stylus is successfully connected: Go to remove and re-connect the stylus. or go to , and check whether the stylus is in the list. If not,
- If the stylus has been paired, troubleshoot as follows:
- Tighten or replace the stylus tip, then try again.
- Write in Notepad pre-installed on the tablet. If the issue is resolved, the third-party app you are using does not support stylus-based writing. You can download the app you need by going to
Skip this step for MatePad Paper.
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- Remove any non-HUAWEI magnetic case from the stylus as they may interfere with the stylus. Use a HUAWEI protective case instead.
- Remove any tempered glass screen protector, then try again. Attaching too thick tempered glass screen protectors to the tablet might cause the stylus to fail to perform as expected.
- When the stylus is connected to more than one tablet at the same time, it takes a while for the stylus to switch between tablets. You can press and hold or draw lines on the tablet screen with the stylus for 1 to 5 seconds before writing. If the tablet still does not respond, go to Unpair. Then attach the stylus to the tablet again for pairing. or , touch the gear icon next to the stylus name, and touch
- Restart your tablet and update the stylus firmware to the latest version. (On your tablet, go to DOWNLOAD & INSTALL and follow the onscreen instructions to update the stylus firmware.) Then restart the stylus by referring to How to restart HUAWEI M-Pencil (2nd/3rd generation) and try again. . If a new version is available, touch
If the issue persists
If the issue persists, back up your data and take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.