HUAWEI MateView flickers or intermittently displays a black screen after being connected to a computer
Applicable products:
HUAWEI MateView flickers or intermittently displays a black screen after being connected to a computer |
Problem
HUAWEI MateView flickers or intermittently displays a black screen after being connected to a computer.
Cause
- The cable is faulty.
- The refresh rate is set to 60 Hz or higher.
- The graphics card does not support the 3840 x 2560 resolution.
- The graphics card driver version is incorrect.
- The Windows system version is incorrect.
Solution
- Check whether both ends of the signal cable are properly connected, and make sure that you use the MiniDP-to-DP/USB-C to USB-C cable delivered with the monitor or a standard HDMI 2.0 cable purchased from an authorized channel.
Figure 1. MiniDP-to-DP cableFigure 2. USB-C to USB-C cable
It is recommended that you use a cable that is 1 to 5 meters long. Once the cable is longer than 10 meters, the signal transmission quality may degrade, resulting in black screen, screen flickering, and unstable images.
- Change the computer's refresh rate to 60 Hz. For details, see Setting the screen refresh rate on a HUAWEI computer.
- Check with the computer vendor or graphics card vendor whether the 3840 x 2560 resolution is supported. If not, change the display resolution to 3600 x 2400 or lower.
- Connect the desktop to another standby monitor. When the image is displayed properly, enter Device Manager in the search box on the taskbar and open it (or press Win+X to directly open Device Manager). Find Display adapters, expand the menu, and right-click the graphics card. Select Update Drivers (P) and click Search automatically for drivers. When the prompt The best drivers for your device are already installed displays, click Close. Alternatively, download the latest graphics card driver from the vendor's official website.
- Check whether there are updates to the Windows system. If so, update the system to the latest version. For details, visit Get the latest Windows update.
If the issue persists
If the issue remains unresolved, feel free to contact Huawei after-sales personnel for assistance.
Thanks for your feedback.