Unable to update an app downloaded via Petal Search
Applicable products: Smartphone
Applicable products:
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Unable to update an app downloaded via Petal Search

Problem:

A message is displayed indicating that an app downloaded via Petal Search needs to be updated, but it cannot be updated to the latest version.

Cause:

  1. The app or the latest version of the app may not be available in the app stores installed on your phone, such as AppGallery and APKPure.
  2. The latest version of the app may not be available in Petal Search. Petal Search has not received the updated version from the third party application market.

Solution:

  1. If the source of the app you downloaded via Petal Search is AppGallery, update AppGallery to the latest version and try to update the app again. If the issue persists, report the issue in the comment section for the corresponding app in AppGallery.
  2. If the source of the app you downloaded via Petal Search is APKPure or other app stores, update Petal Search to the latest version and try to update the app again. If the issue persists, go to Petal Search > Me > Feedback (For versions earlier than 12.0.2) or Petal Search > Me > Help & feedback > Online support (For 12.0.2 and later) to report the issue and provide the following information:
    • Name of the app to be updated
    • App source
    • Search language and region
    • Petal Search version: To view your Petal Search version, go to Petal Search > Me > About.
    • Phone model and EMUI version: To view your phone model and EMUI version, go to Settings > About phone.
  3. Please be patient, we will provide you the lastest version when we receive it from the third party app market.

To check the Petal Search app version, go to:

  • For versions earlier than 12.0.2: Petal Search > Me > About
  • For 12.0.2 and later: Petal Search > Me > Gear icon in the upper-right corner > About
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