Fingerprint login does not work/Unable to enroll my fingerprint/No option for setting up fingerprint login

Applicable products: HUAWEI MateStation S Series,PC,HUAWEI MateStation B Series
Applicable products:
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Fingerprint login does not work/Unable to enroll my fingerprint/No option for setting up fingerprint login

Problem

  • The screen cannot be unlocked with a fingerprint/Attempt to enroll a fingerprint fails/No option is available for setting up fingerprint login.
  • A message is displayed on the fingerprint settings screen indicating that fingerprint identification is unavailable.
  • Before a password is set, the button for setting a fingerprint is grayed out.
  • On the fingerprint enrollment screen, when the user touches the fingerprint sensor, the error message "Sorry, something went wrong. Close Windows Hello, then try going through the setup again." is displayed.
  • The progress bar does not respond when the user touches the fingerprint sensor to set a fingerprint.
  • While the user is setting a fingerprint, the Windows Hello app crashes or no pop-up window is displayed.

Cause

  • Huawei PC Manager or the fingerprint driver is not updated to the latest version.
  • You have not set a password or PIN code before setting your fingerprint, or the PIN code is not working correctly.
  • You are using a super administrator account.
  • The fingerprint feature is unavailable because you do not have the required account control permissions.
  • A maximum of 10 fingerprints can be enrolled for each account. The fingerprint cannot be enrolled if you attempt to enroll an 11th fingerprint.
  • Fingerprint identification cannot be used due to incompatibility between the reinstalled system and the device.

Solution

  1. Update Huawei PC Manager and the fingerprint driver to their latest versions.
    1. Update Huawei PC Manager to the latest version. For details, see Updating PC Manager to the latest version.
    2. To update the fingerprint driver, go to Huawei PC Manager > Optimization > Drivers > Check for updates, select all items to be updated, and click UPDATE. After the update is complete, restart your computer.
       
      1. Do not power off your computer, or press the Power button or fingerprint key while updating.
      2. You'll need to restart the computer for the update to take effect.
  1. You have not set a password or PIN code before setting your fingerprint, or the PIN code is not working correctly.
    1. Make sure that you have set a password and PIN for your account.
    2. Delete the PIN code, set a new PIN code, and then set up the fingerprint login again.
  2. According to the Windows system settings, you cannot set fingerprints using a super administrator account. Switch to a non-super-administrator account, or create a regular account to set fingerprints. The procedure is as follows:
     
    1. If the computer has only one account, do not disable the super administrator permissions. Otherwise, you may not be able to log back in to the system.
    2. Disconnect the Internet connection before creating a local account.
    1. To check whether you are using a super administrator account, type cmd into the search box on the taskbar and open it. If you see C:\Users\Administrator in the pop-up window, you are using a super administrator account.
    2. If your account is a super administrator account, press Win+R to open the Run window, enter netplwiz, and click OK. In the user account window, click Add account and then Add local account.
    3. In the user account window, select your account and click Properties. In the Properties dialog box, click the Group Membership tab, and then go to Administrator > OK. In the user account window, click OK.
    4. After the settings are complete, restart the computer, log in to the computer using the newly created local account, enter the system, and enroll your fingerprint again.
  1. The fingerprint feature is unavailable when you do not have the required account control permissions. If the fingerprint settings screen cannot be opened when you enroll your fingerprint, and the Windows Hello app crashes or does not display a window when you set your fingerprint, check whether the user account control permission settings are correct. Type Change User Account Control settings into the search box on the taskbar and select Notify me only when apps try to make changes to my computer.
  2. You are only able to enroll up to 10 fingerprints for each account on your computer. When you attempt to enroll an 11th fingerprint, an error message will appear, indicating that the fingerprint is too similar to existing ones, and that you should try a different finger. If you can enroll more than 10 fingerprints, some of the fingerprints that you have already enrolled may be invalid.
  3. If the issue remains unresolved, back up your data, record your Office account, and use F10 to restore your computer to its factory settings.
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