Audio stutters after my HUAWEI computer is connected to a Bluetooth headset or speaker
Applicable products: PC,Desktop
Applicable products:
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Audio stutters after my HUAWEI computer is connected to a Bluetooth headset or speaker

Problem

  1. Audio stutters when the computer plays an audio file through a connected Bluetooth headset or speaker during Bluetooth file transfer.
  2. Audio stutters when the computer connected to a 2.4 GHz Wi-Fi network searches for Bluetooth devices while playing an audio file through a connected Bluetooth headset or speaker.
  3. Audio quality deteriorates when a Bluetooth headset or speaker is reconnected to the computer, after the computer is powered off and then powered on.
  4. When the user uses a Bluetooth headset or speaker connected to the computer to play music and accesses the Bluetooth settings screen to search for available devices, the music playback stutters and noises are audible. The music starts playing normally again after the user exits the searching screen.

Cause

  1. The priority of Bluetooth file transfer is high, which occupies a lot of resources. As a result, audio stuttering will occur on the Bluetooth headset or speaker that is used to play music.
  2. This is due to a priority issue between Wi-Fi and Bluetooth channels. If the computer searches for Bluetooth devices while having run Wi-Fi and Bluetooth services, scanning resources will be preferentially allocated to searching, causing audio on the Bluetooth headset or speaker to stutter.
  3. In normal cases, when the computer is connected to a Bluetooth headset or speaker, the Bluetooth protocol uses Stereo mode for music playback, and Hands-Free AG audio mode for calls and recording. The former features a better music playback effect than the latter.
  4. When the computer plays music through a connected Bluetooth headset or speaker, searching for Bluetooth devices may occupy certain resources. This may be caused by insufficient available Bluetooth channel resources or compatibility issues with the Bluetooth headset or speaker.

Solution

  1. Stop transferring Bluetooth files or play audio after the file transfer is complete.
  2. Connect the computer to a 5 GHz Wi-Fi network and try again, or play audio after the computer finishes searching for Bluetooth devices.
  3. Delete the Bluetooth headset or speaker pairing records and pair them again.
  4. Right-click the Windows Start icon, go to Settings > Devices > Bluetooth & other devices, delete pairing records related to other Bluetooth peripherals that are not frequently used, and reconnect to the Bluetooth headset or speaker. If the issue persists, try again after the computer finishes searching for Bluetooth devices.

    Generally, the computer can connect to a maximum of seven Bluetooth devices at the same time. To ensure that it works stably, it is recommended that you do not connect it to more than five Bluetooth devices at the same time.

If the issue persists

If the issue persists, back up your data, save your Office account, and use F10 to restore your device to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.

To learn more

Connecting a HUAWEI computer to a Bluetooth device

It takes about 20 seconds for audio to play via the speaker after I forcibly turn off the connected Bluetooth headset

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