The step count of the current day in the Huawei Health app increases/decreases/does not reset

Applicable products: Wearable
Applicable products:
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The step count of the current day in the Huawei Health app increases/decreases/does not reset

Problem

  • The step count in the Huawei Health app is inaccurate or does not reset when the time zone changes.
  • On an Android or HarmonyOS phone, the step count does not reset after midnight (00:00), or the step count suddenly increases in the morning.
  • The step count on the HUAWEI watch/band won't reset back to zero

Cause

  • The step count is measured on a daily basis, and the Huawei Health app reports the current day's step count in real time. The midnight (00:00) step count reset takes place at different times depending on the time zone, so when the time zone changes, the first and last reported times change as well, causing the step count to become inaccurate.
  • If you manually set the phone system time, the step count will be recorded for that day. Later, when you switch back to the correct time and reach that day again, the data will be displayed.
  • The step count on your watch/band will automatically reset to zero at 00:00 every day. If the time on your watch/band is inconsistent with the actual time, the step count data generated during this time period may not go back to zero, as workout data generated during this time period will be stored on the cloud server and used as the data for the next day.

Solution

  1. Please do not be concerned. When the time zone changes, the Huawei Health app will adjust to the time zone and start counting steps normally the following day. Close the Huawei Health app and open it again to check whether data is restored. If this issue occurs frequently, enable Airplane mode on your phone during your walks. This will disconnect your phone from the Internet, making it unable to recognize time zone changes.
  2. If data does not automatically reset at 00:00 midnight, follow these steps:

The current day's step count is calculated as follows:

If the phone has not been restarted during the day: Step count = The final step count reported for that day (for example, reported at 23:59) – The first step count reported for that day (for example, reported at 00:00)

If the phone has been restarted during the day: Step count = Step count before the phone was restarted + Step count after the phone was restarted

If the issue persists or you encounter any difficulties, please call the Huawei customer service hotline for assistance. We will do our best to address your needs.

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