The space of the C drive on my HUAWEI computer is insufficient
Applicable products:
PC,Desktop
Applicable products:
The space of the C drive on my HUAWEI computer is insufficient |
Problem
The remaining space in the computer's C drive decreases over time.
Cause
- The C drive stores too much data.
- Unnecessary temporary files are generated during Windows updates.
- Temporary files are generated during use.
- Temporary files are left over when installing third-party software.
Solution
- Clear user data regularly.
- Check whether there are large files on the desktop and whether the Downloads folder contains a large number of downloaded files and data in folders of other users. For details, see Changing the location for saving desktop files on the computer.
- Check whether the chat history of third-party apps needs to be deleted. You can view the chat history of a third-party app in the C drive. For example, the chat history of WeChat is stored by default to C:\Users\User name\Documents\Wechat Files\; the chat history of QQ is stored by default to C: \Users\User name\Documents\Tencent Files\. (You are not advised to delete them. To move the chat history to the D drive or another non-system drive, go to
For details about how to move cache files of common chat software, such as WeChat and QQ, see Migrating files from the C drive to another drive (such as the D drive).
on WeChat, for example.)
- Use the C drive properly.
- Store personal data in disks other than the C drive. For details, see Backing up the computer's hard disk data.
- Uninstall unnecessary third-party software. For details, see Uninstalling updated software in Safe Mode.
- Change the path for downloading and installing software to another disk. For details, see Changing the default location for new apps downloaded from Microsoft Store.
- Manage desktop files regularly, as they are also stored on the C drive.
- Use the System disk downsizing or Large file cleanup feature of Huawei PC Manager to clean up the system disk regularly.
- Update Huawei PC Manager to 13.0.6.360 or a later version. For details, see Updating Huawei PC Manager to the latest version.
- Open Huawei PC Manager, go to
- Not all the scanned or listed files can be deleted using System disk downsizing or Large file cleanup. Ensure that the files to be deleted are truly of no use before deleting them. Do not delete a file if you are not certain about whether it is useless or not.
- Before using the System disk downsizing feature, close third-party apps running in the background (especially WeChat, WeCom, QQ, WPS Office, WPS Cloud, Sohu Player, and so on).
- The System disk downsizing feature moves files to D:\HuaweiMoveData by default. (This is a hidden folder.)
, and follow the onscreen instructions to perform operations with caution.
- Delete temporary files regularly.
- On Windows 10, perform the following steps:
- Press Win+I to enter the Windows Settings screen.
- Go to Storage is turned on, and click Configure Storage Sense or run it now. , make sure that the switch under
- Click Clean now under Free up space now.
- On Windows 11, perform the following steps:
- Press Win+I to enter the Settings screen, and go to .
- Go to to delete the files selected by default.
- Return to the Storage window and click Storage Sense.
- Turn on the switch under Cleanup of temporary files and the switch under Automatic User content cleanup.
- On Windows 10, perform the following steps:
- If the issue persists, back up the data in the D drive. Then, transfer the space of the D drive to the C drive by referring to Merging the C drive with other drives (such as the D, E, F, and G drives), and recreate the D drive by referring to Creating or deleting disk partitions.
- If the issue remains unresolved, back up your data and record your Office account in advance, then use F10 to restore your computer to its factory settings. If the proceeding method does not work either, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.
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